炒股公式源码(炒股公式大全)

2023-10-21 03:31:37
股票学习网 > 怎样炒股票 > 炒股公式源码(炒股公式大全)

本篇文章给大家谈谈炒股公式源码,以及炒股公式大全的知识点,希望对各位有所帮助,不要忘了收藏本站喔。

文章详情介绍:

教你如何用上升三部曲轻松选出强势大牛股(内附指标源码),买入就涨,轻松抓黑马股

股市有风险,投资需谨慎。这句话肯定都是听说过的,大多散户应该更清楚,但是应该怎么面对这些股票风险呢,散户如何控制股票风险呢。

第一,有备而来:无论什么时候,买股票之前就要盘算好买进的理由,并计算好出货的目标。千万不可盲目地进去买,然后盲目地等待上涨,再盲目地被套牢。

第二,一定设止损点:凡是出现巨大亏损的,都是由于入市的时候没有设立止损点。而设立了止损点就必须执行。即便是刚买进就股票套牢,如果发现错了,也应卖出。做长线投资的必须是股价能长期走牛的股票,一旦长期下跌,就必须卖!

第三,优选个股,避免地雷股:可以即用筛选法、排除法、比较法、定性定量法选择小盘、绩优、含权、中价、成长性好的个股,领先一步,耐心做中线。

第四,不怕下跌怕放量:有的股票无缘无故地下跌并不可怕,可怕的是成交量的放大。尤其是庄家持股比较多的品种绝对不应该有巨大的成交量,如果出现,十有八九是主力出货。所以,对任何情况下的突然放量都要极其谨慎。

上升三部曲又叫做升势三鸦,或称N型反转走势,较多出现在股价上升趋势途中。一般情况下,不出意外,在上升三部曲出现之后,股价都会形成一轮较大的升势。

它的表现图形为:

来看个彩色的。

形态要点:

1、升势三鸦出现在上升行情途中才视为有效;

2、升势三鸦前后由大阳线或中阳线组成,中间一般为小阴线;

3、标准的升势三鸦形态中有三连阴形态(一般为三只乌鸦形态),此时不要认为股价就会转弱;分辨的标准可以参考均线是否形成有效支撑。

4、升势三鸦是比较好的上涨中继,多头的力量比较强大,在小级别的周期上进行调整就继续向上进攻,有利于筹码的稳定性,上涨比较顺畅。

实战图例:

1.(2016.10.24冀东水泥)

如上图所示,股价在相对低位横盘震荡后,在突破前期形态高点位置出现上升三法组合形态,而且量价表现健康,符合整体要求,而且之后股价也从未跌破过买进点,并且后市有一波强势涨升。

2.(2016.12.23渝开发)

如上图所示,股价从相对低档起涨以后,在前期形态高点位置出现上升三法结构(上图没有截取前期形态高点,投资者可以自己在软件上看),并且量价结构也符合模型买点,并且之后再没有阴线跌破过进场点的大阳线的低点。

上升三法结构和二阳夹一阴的组合形态很相似,但成功率会比二阴夹一阳来的更高,主要原因是中间三根小阴线的洗盘时间更久带来的效果,所以大家在分析个股的时候,一定要谨慎对待洗盘结构,分清楚骗线的内在逻辑。

附上升三部曲选股公式:

n=2;

C1:=REFX(C,1)*1.01;

O1:=REFX(O,1)*0.99;

C2:=REF(C,N)*1.01;

O2:=REF(O,N)*0.99;

{

T0:=(REF(C,N)-REF(O,N))/REF(O,N)*100>3;{N日前涨幅>3%}

T5:=(REFX(C,1)-REFX(O,1))/REFX(O,1)*100>3;{最后一日的涨幅>3%}

T1:=BETWEEN(HHV(C,N+1),O1,C1) AND BETWEEN(HHV(O,N+1),O1,C1);

T2:=BETWEEN(LLV(C,N+1),O1,C1) AND BETWEEN(LLV(O,N+1),O1,C1);

T3:=BETWEEN(HHV(C,N),O2,C2) AND BETWEEN(HHV(O,N),O2,C2);

T4:=BETWEEN(LLV(C,N),O2,C2) AND BETWEEN(LLV(O,N),O2,C2);

BARSLAST(T0 AND T1 AND T2 AND T3 AND T4 AND T5)>1;

最后需注意的是:

1、上升三部曲在K线组合形成的过程中,成交量的配合非常重要。要求上升三部曲第一根中阳线或大阳线向上启动攻击时,要求带量攻击,或称放量攻击。

2、随后回调整理的小阴线、小阳线要求实体一定要小,并且成交量配合出现逐渐萎缩的态势。只有股价回调,成交量配合逐渐萎缩,才可以看作是缩量洗盘行为。

3、最后一根象征洗盘结束,再次启动攻击的中阳线或大阳线要求成交量再次放大。也就是说成交量也应当配合走出三步组合放量、缩量、再次放量的走势。

4、最后一根阳线实体越长,超越第一根阳线实体部分越多,后市股价上涨的概率越高。同时最后一根阳线成交量放得越大,后市股价惯性向上攻击的能量也就越强。

正确炒股心态

1、对炒股要有浓厚的兴趣

无论是炒股还是工作,要想将其做好都要有足够的兴趣。如果你不喜欢文字,那么你愿意待在办公室写一整天的稿件吗?如果你不喜欢营销,你愿意每天对着无数陌生人推销产品吗?显而易见,我们都不愿意。因此正确的炒股心态第一点就是要对炒股票有浓厚的兴趣,只有在浓厚的兴趣支持下你才会尽力去搜集相关资料,然后认真学习证券专业知识,这是炒股最基本的条件与心态。

2、要有自信心。

要想成功,自信心是最为重要的。股票投资讲究的是“快、准、狠”,但是能够做到以上几点的并不多,因为这是投机高手的绝技。初入股市的股民要调整好自己的心态,保持自信的状态,打破“不可能做到”的壁垒。人的潜力是无穷的,没有做不到,只有你想不想做到,如果你自己给自己打上一个“我做不到”的标签,那么你必然无法达到这个目的。有时候多回想下李白的名句“天生我材必有用”,拿出你的勇气,鉴定你的信念,你一定可以成功!

3、让恐惧远离,叫贪婪走远

也许有人会说:“我进股市就是为了赚钱,怎么可能不贪婪呢?”如果你是这样的想法那么有必要提醒你,你的贪婪会让你变得一无所有。股票市场大起大落,你不仅仅要学会如何抓住时机赚钱,更重要的是学会放手,克服贪婪心理,不然,你和赌徒有何区别?至于克服恐惧,需要的是股民具备足够的股票知识,心理有了底,自然就不再担心与害怕股市浮沉了!

如果您喜欢以上文章,想了解更多股市投资经验及技巧,关注公众号越声攻略(yslc688),干货很多!

声明:本内容由越声攻略提供,不代表投资快报认可其投资观点。

十大神仙炒股公式,请收好

1.神仙大趋势

神仙大趋势H1:EMA(CLOSE,6);

H2:EMA(神仙大趋势H1,18);

H3:EMA(CLOSE,108),COLORYELLOW;

STICKLINE(神仙大趋势H1>H2,神仙大趋势H1,H2,1,1),COLORRED;

STICKLINE(神仙大趋势H1

2.神仙三线

A:=MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1));

B:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);

分水岭:IF(MA(CLOSE,17)

操作线:分水岭-(EMA(C,3)-分水岭),COLORGREEN,LINETHICK2;

PM:MA(C,5),COLORWHITE,LINETHICK2;

IF(PM>REF(PM,1),PM,DRAWNULL),COLORRED,LINETHICK2;

IF(PM=REF(PM,1),PM,DRAWNULL),COLORRED;

IF(PM

S:=(PM>操作线);

DD:=分水岭

IF(DD,分水岭,DRAWNULL),COLORYELLOW,LINETHICK2;

IF(S,分水岭,DRAWNULL),COLORYELLOW,POINTDOT,LINETHICK4;

DRAWICON(CROSS(分水岭,操作线),分水岭-0.1,1);{买入红箭头}

A1:=BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1));

B1:=REF(C,A1+1)>C AND REF("MACD.DIF",A1+1)<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA");

DRAWTEXT(B1>0,L-0.02,'★M'),COLOR00FFFF;{MACD底背离}

A2:=BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1));

B2:=REF(C,A2+1)>C AND REF("KDJ.K",A2+1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D");

DRAWTEXT(B2,L-0.10,'◎K'),COLORFF00FF;{KDJ底背离}

A3:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));

B3:=REF(C,A3+1)>C AND REF("RSI.RSI1",A3+1)<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2");

DRAWTEXT(B3>0,L-0.18,'◆R'),COLOR0000FF;{RSI底背离}

C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1));

D1:=REF(C,C1+1)"MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF");

DRAWTEXT(D1>0,H+0.16,'★M'),COLOR00FF00;{MACD顶背离}

C2:=BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1));

D2:=REF(C,C2+1)"KDJ.K" AND CROSS("KDJ.D","KDJ.K");

DRAWTEXT(D2>0,H+0.08,'◎K'),COLORFFFFCC;{KDJ顶背离}

C3:=BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1));

D3:=REF(C,C3+1)"RSI.RSI1" AND CROSS("RSI.RSI2","RSI.RSI1");

DRAWTEXT(D3>0,H+0.04,'◆R'),COLORFF9900;{RSI顶背离};

3.神仙抄底

VAR2:=TROUGHBARS(3,15,1)<10;

VAR3:=PEAKBARS(3,15,1)<10;

VAR4:=IF(VAR2=1,50,0);

VAR5:=IF(VAR3=1,50,0);

底部:=IF(VAR4=50,10,0);

多头能量:0,COLORWHITE,LINETHICK2;

买入:IF(底部=10 AND REF(底部,1)=10 AND REF(底部,2)=0,50,0),COLOR0000CC,LINETHICK2;

买入延迟线:底部,LINETHICK1 ,COLOR00CCFF;

4神仙敢死队

R1:=150*WINNER(CLOSE*0.95);

VAR3:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),5);

VAR4:=(CLOSE-LLV(CLOSE,126))/(HHV(CLOSE,126)-LLV(CLOSE,126))*100;

VAR5:=EMA(CLOSE,2)-EMA(CLOSE,120);

VAR6:=EMA(VAR5,68);

VAR7:=(VAR5+VAR6);

敢死:=POW(VAR7,3)*0.1+POW(VAR7,1);

核心:=MA(敢死,30),COLORRED,;

涨停:=1;{DYNAINFO(14)>0.096;}

警:涨停*核心/5,COLORRED,LINETHICK2;

Y:MA(警,6),COLORRED,LINETHICK2;

IF(Y

Y1:警-Y,COLORBROWN;

IF(警

{STICKLINE(CROSS(MA(警,1),MA(警,2)),0,警,1,0),

COLORYELLOW;}

G:=C>=INTPART(REF(C,1)*1.08*100+0.5)/100;

G1:=G*核心/5;

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=(SMA(RSV,3,1));

D:=(SMA(K,3,1));

KK:=INTPART(SMA(RSV,3,1));

DD:=INTPART(SMA(K,3,1));

N:=KK+DD;

涨停信号:ABS((10000*(C-REF(C,1))/REF(C,1)>995)*G1),COLORGREEN;

促击:FILTER(BACKSET(涨停信号,2),2)*G1,COLORGREEN;

预涨停:IF(CROSS(N,100),ABS(警),0),COLORYELLOW;

DRAWTEXT(CROSS(N,100),预涨停*1.2,'预'),COLORCYAN;

DRAWTEXT(涨停信号>0,涨停信号*1.1,'停'),COLORCYAN;

5神仙建仓

VAR1:=REF(LOW,1);

VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),13,1);

VAR3:=EMA(VAR2,13);

VAR4:=LLV(LOW,34);

VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);

主力进场:STICKLINE(VAR5>REF(VAR5,1),0,VAR5,3,0),COLORRED;

VAR2;VAR5;

6神仙提款机

尖顶买入:ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)

(3,10),2),COLORRED,LINETHICK2;

尖顶卖出:ZIG(3,10)

REF(ZIG(3,10),2),COLORGREEN,LINETHICK2;

DRAWTEXT(尖顶买入=1,1,'入!'),COLORRED;

DRAWTEXT(尖顶卖出=1,1,'出!'),COLORGREEN;

7.神式买卖点

VAR1:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),25);

VAR2:=HIGH-REF(HIGH,1);

VAR3:=REF(LOW,1)-LOW;

VAR4:=SUM(IF(VAR2>0 AND VAR2>VAR3,VAR2,0),25);

VAR5:=SUM(IF(VAR3>0 AND VAR3>VAR2,VAR3,0),25);

VAR6:=VAR4*100/VAR1;

VAR7:=VAR5*100/VAR1;

VAR8:=MA(ABS(VAR7-VAR6)/(VAR7+VAR6)*100,15);

VAR9:=(VAR8+REF(VAR8,15))/2;

A:=(VAR7>VAR6 AND VAR7>25 AND VAR6<25);

B:ZIG(3,50/5)*100,COLORWHITE;

G:MA(B,2),COLORYELLOW;

D:=CROSS(B,G)*1000,COLORRED;

W:=CROSS(G,B)*1000,COLORBLUE;

E:=REF(INDEXC,1);

F:=SMA(MAX(INDEXC-E,0),3,1)/SMA(ABS(INDEXC-E),3,1);

VAR10:=F AND F<8;

VAR11:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

VAR12:=SMA(VAR11,3,1);

VAR13:=SMA(VAR12,3,1);

VAR14:=VAR13 AND VAR13<20;

MM:=A AND D AND VAR10 AND VAR14;

DRAWTEXT(W=1000,B*1.05,'卖'),COLOR00FF00;

DRAWTEXT(D=1000,B*1.05,'买'),COLORRED;

8.神式阴线买入

VAR11AA:=EMA(CLOSE,30)-EMA(CLOSE,17);

VAR12AA:=EMA(VAR11AA,5);

九:=TROUGHBARS(3,10,1)<1 AND CROSS(VAR11AA,VAR12AA);

DRAWICON(九>0,8,1);

DRAWTEXT(九,99,'九'),COLOR000000;

VAR2A:=(EMA(CLOSE,26)-EMA(CLOSE,52))/MA(CLOSE,60)*100;

VAR3A:=EMA(VAR2A,18);

VAR4A:=VAR2A<-1;

VAR5A:=VAR4A AND CROSS(VAR2A,VAR3A);

追2:=VAR5A;

追涨C:=IF(追2>0,0.8,0),STICK,COLORYELLOW,LINETHICK4;

XX:=EMA(CLOSE,30)-EMA(CLOSE,17);

YY:=EMA(XX,13);

短针2:=TROUGHBARS(3,5,1)<1 AND XX

阴:=IF(短针2>0,0.4,0),STICK,COLORF0F000,LINETHICK4;

DRAWICON(阴>0,8,1);

DRAWTEXT(阴,85,'阴'),COLOR000000;

N1:=30;N2:=17;N3:=5;N4:=6;

VAR1X:=EMA(CLOSE,N1)-EMA(CLOSE,N2);

VAR2X:=EMA(VAR1X,N3);

剑:=CROSS(VAR1X,VAR2X) AND TROUGHBARS(3,7,1)<1;

DRAWICON(剑>0,8,1);

DRAWTEXT(剑,73,'剑'),COLOR000000;

阴剑:九 OR 剑 OR 阴;

9.神仙顶底先知

CS:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;

YJD:(EMA(CS,3)-50)*2;

极弱:-80;

强势:60;

风险:80;

弱势:-60;

YJD,COLORSTICK;

10.神仙短线精灵

VAR1:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;

持币区域:VAR1,COLORFEDCBA;

持股区域:IF(VAR1>0,VAR1,0),COLORRED;

短顶:STICKLINE(VAR1>9 AND FILTER(VAR1

大顶:STICKLINE(VAR1>20 AND FILTER(VAR1

VAR2:=HHV(VAR1>20,10);

危险:STICKLINE(VAR2 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),VAR1+10,0,4,0);

注意止损:STICKLINE(VAR2 AND FILTER(VAR1

短底:STICKLINE(VAR1<-9 AND VAR1>REF(VAR1,1),VAR1-2,0,3,0),COLORRED;

大底:STICKLINE(VAR1<-20 AND FILTER(VAR1>REF(VAR1,1),5),VAR1-5,0,7,0),COLORYELLOW;

买入准备:VAR1<-9 AND VAR1>REF(VAR1,1),COLORWHITE;

作者:piikee | 分类:怎样炒股票 | 浏览:21 | 评论:0